Quests 2.0 - Testland 0.9.8.1T

We are finally ready for the first public test! :partying_face::partying_face::partying_face:

Accounts created before 2019-09-09T12:00:00Z can now download and play around with our Testland version.

Please use this thread to discuss this update

For those that are new, please follow our Testland Tutorial

4 Likes

App nao foi instalado ,:rage::exploding_head:

Did you follow the Troubleshooting section here Testland Tutorial?

1 Like


Typo: it should be (you’re)


The quests don’t take into account if you already had the items in your inventory. They only track new drops. Notice I had plenty of leather and eyeballs in stock to finish the quest. Also, the observers and deathwatch both drop ‘leather’. Since the deathwatch already drop magic eyeballs why not change the name to magic leather to match? That is all for now…

Oh, relogging didn’t help the quest tracker update either.

Its supposed to only count for quest once you have the quest active then have items drop. Any item obtained before quest just pools up. They will be used for crafting and what not in the future.

As for the leather thing, it is two different names on our sheet, think its just simplified in game.

So is it intentional that the craft items aren’t removed from your inventory after completing a quest that asks for them?

Not sure entirely, id say probably not. Ill have alk verify though.

My system 86x,:sob: nooooot

The devil square quests aren’t tracking any enemy kills or how many times I entered.


More typos: those should be (special) and (familiarize)


The quest tracker didn’t update even though I visited all of those places. Only the potion shop updated.

Only the bank seems glitched for me.


Are snake venom like 0.01% drop rate? I swear they’re dropping less than slime cores.

You guys should increase the drop rate of the 2nd craft item for every monster. Some of these quests are taking over 30 minutes to complete.

I can no longer open my quest log. I’ve tried relogging and still no go. I can’t keep testing quests without it. Also, you should add a button for the quest log next to the event exchange button. It’s time consuming having to press menu and then quest log every time you complete a quest. Or better yet, the quests should auto complete like they do now once you finish them. It’ll save quite a bit of time.

Welcome to the forums!

Yes, we are not removing any items on quest completion and quests only track material pickups

It took me a while but I was able to replicate the bug and fix it. I will fix more bugs and then recompile a new testland version. In the mean time I have reseted your quest log so you can keep testing.

I had no issue with any of these locations @Quickdraw @Zelp

image

Are you entering the place and leaving in less than a second?

No, I stood in each place for a good minute. I even bought items from the npcs to see if maybe that triggered it and it still didn’t work.

Yeap I found the bug and it should be fixed now.

Thanks

0.9.8.1T is now online with many bug fixes but not all of them.

Minor things like typos will be fixed in next release

I also enabled x86 and ARMv6 support, all in one APK.